Windows 10 Mobile Probleme bei SMS-TAN und APN Bug

bugViele Nutzer eines aktuellen Windows Phone Gerätes werden es sicherlich das ein oder andere Mal zwecks Onlinebanking zur Hand nehmen.

Dabei ist es egal, ob das Gerät nur als Übermittler eine TAN dient, oder man auf dem Gerät selber eine Banking-App nutzt. Solange von der Bank eine TAN zur Verfügung gestellt wird, kann es zu Problemen kommen.

Dies äußert sich darin, dass die von der Bank gesendete TAN nämlich nicht auf dem Gerät ankommt. So z.B. bei dem Versand der TAN bei den Sparkassen. Diese werden so wie es scheint zwar als SMS versendet, greifen aber auf die MMS Einstellungen zur Authentifizierung zurück.

Auffällig dabei ist auch, dass bei den APN Voreinstellungen kein Versenden und Empfangen von MMS möglich ist (getestet mit Vodafone). Beim Vergleich zwischen den APN Einstellungen von Windows Phone 8.1 und Windows 10 Mobile gibt es keine Unterschiede, sodass ebenso eine mangelnde Protokoll- Unterstützung in Frage kommt.

Nach einem Rollback auf WP 8.1 funktionierte das SMS TAN Verfahren einwandfrei. Der Versuch eigene APN Datensätze einzupflegen schlug fehl, Windows 10 Mobile meldete, dass das Aktivieren der APN nicht möglich sei. Die Meldung erhält man allerdings auch, wenn man versucht anschließend wieder den Standard APN zu übernehmen.

Dann sind alle APN Funktionen außer Gefecht gesetzt und nur ein Neustart des Telefons  schafft Abhilfe. Bei Tests gab es sogar das Problem, dass nach dem Neustart keine PIN abgefragt wurde. Das kann man aber nachholen, indem man den Hörer abnimmt und wählt, dann erscheint die PIN Abfrage.

[NACHTRAG]

Mit den APN hatte es nichts zu tun, der Fehler wurde mit der Build 0.29 behoben. Anscheinend sind gesetzte Flags das Problem. Siehe auch: SMS Bug betrifft nicht nur TANs- es geht noch dicker


8 Gedanken zu “Windows 10 Mobile Probleme bei SMS-TAN und APN Bug

    • Bisher habe ich noch keine Rückmeldungen. Das Problem scheint sich aber nicht nur auf die Sparkassen zu beschränken. Eine Info an die Produktgruppe bei Microsoft ist samt Beschreibung raus.
      Aktuell hilft nur „Abwarten“. Leider…

          • Also auf meinem 1020 mit der neuesten W10M Version .29 funktioniert es einwandfrei. Bekomme bald auch das 950xl und ich hoffe bisdahin hat Microsoft ein Fix fertig. Seltsam das dieses Problem auch nirgendswoanders thematisiert wird.

          • Sorry, Denkfehler. War noch beim MMS Problem. Hm, gleiche Software (die .29 ist in der Insider Preview aber anders aufgebaut, als auf Mobiles mit Win10M und der gleichen Build .29). Ich werde Testhalber mal das 625 (was wegen eben dem Problem wieder 8.1 drauf hat) wieder auf die aktuelle Preview Build bringen.

Kommentar verfassen